Chat with us, powered by LiveChat
Menu

What are the minimum device requirements?

The minimum device requirements are:

iOS –  The phone must be an iPhone 4S, 5, 5C, 5S, 6, 6 Plus, 6S, 6S Plus, SE, 7, or 7 Plus running iOS 8 or later. However, for best results: Use iPhone 5 or newer

Android – Any smart phone from 2013 or newer with Android version 4.0 or newer. However, for best results the phone should run Android 5.0 or newer

The app is currently not compatible with any tablets at this time.